<!doctype html><html lang=en-US class=gnt__njs><head><meta charset=utf-8 /><meta name=viewport content="width=device-width,initial-scale=1,minimum-scale=1"/><meta name=theme-color content=#0098FE /><title>Arrest report</title><meta property=og:title content="Arrest report"/><link rel=amphtml href=https://amp.apalachtimes.com/amp/3651742001 /><meta property=article:content_tier content=metered /><meta property=article:opinion content=false /><link rel=dns-prefetch href=//user.apalachtimes.com /><link rel=preconnect href=https://user.apalachtimes.com /><link rel=dns-prefetch href=//content-static.gannett.com /><link rel=dns-prefetch href=//www.gannett-cdn.com /><link rel=dns-prefetch href=//securepubads.g.doubleclick.net /><link rel=preconnect href=https://securepubads.g.doubleclick.net /><link rel=dns-prefetch href=//adservice.google.com /><link rel=preconnect href=https://adservice.google.com /><link rel=dns-prefetch href=//tpc.googlesyndication.com /><link rel=preconnect href=https://tpc.googlesyndication.com /><link rel=dns-prefetch href=//googleads.g.doubleclick.net /><link rel=dns-prefetch href=//s0.2mdn.net /><link rel=dns-prefetch href=//partner.googleadservices.com /><link rel=dns-prefetch href=//www.googletagservices.com /><link rel=preconnect href=https://www.googletagservices.com /><link rel=dns-prefetch href=//static.adsafeprotected.com /><link rel=preconnect href=https://static.adsafeprotected.com /><link rel=dns-prefetch href=//pixel.adsafeprotected.com /><link rel=preconnect href=https://pixel.adsafeprotected.com crossorigin/><link rel=dns-prefetch href=//c.amazon-adsystem.com /><link rel=preconnect href=//c.amazon-adsystem.com /><link rel=dns-prefetch href=//js-sec.indexww.com /><link rel=preconnect href=https://js-sec.indexww.com /><link rel=dns-prefetch href=//aax.amazon-adsystem.com /><link rel=preconnect href=//aax.amazon-adsystem.com /><link rel=dns-prefetch href=//fastlane.rubiconproject.com /><link rel=preconnect href=https://fastlane.rubiconproject.com /><link rel=dns-prefetch href=//bidder.criteo.com /><link rel=preconnect href=https://bidder.criteo.com /><link rel=dns-prefetch href=//static.criteo.com /><link rel=dns-prefetch href=//colossusssp.com /><link rel=preconnect href=https://colossusssp.com /><link rel=dns-prefetch href=//gannett-d.openx.net /><link rel=preconnect href=https://gannett-d.openx.net /><link rel=dns-prefetch href=//hbopenbid.pubmatic.com /><link rel=preconnect href=https://hbopenbid.pubmatic.com /><link rel=dns-prefetch href=//ads.pubmatic.com /><link rel=dns-prefetch href=//as-sec.casalemedia.com /><link rel=preconnect href=https://as-sec.casalemedia.com /><link rel=dns-prefetch href=//ib.adnxs.com /><link rel=preconnect href=https://ib.adnxs.com /><link rel=dns-prefetch href=//adserver.adtechus.com /><link rel=preconnect href=https://adserver.adtechus.com /><link rel=dns-prefetch href=//apex.go.sonobi.com /><link rel=preconnect href=https://apex.go.sonobi.com /><link rel=dns-prefetch href=//sofia.trustx.org /><link rel=preconnect href=https://sofia.trustx.org /><link rel=dns-prefetch href=//tlx.3lift.com /><link rel=preconnect href=https://tlx.3lift.com /><link rel=dns-prefetch href=//e.serverbid.com /><link rel=preconnect href=https://e.serverbid.com /><link rel=dns-prefetch href=//confiant-integrations.global.ssl.fastly.net /><link rel=preconnect href=https://confiant-integrations.global.ssl.fastly.net /><link rel=preconnect href=https://s0.2mdn.net /><link rel=preconnect href=https://ads.adaptv.advertising.com /><link rel=preconnect href=https://search.spotxchange.com /><link rel=preconnect href=https://static.adsafeprotected.com /><link rel=preconnect href=https://imasdk.googleapis.com /><link rel=dns-prefetch href=//ads.adaptv.advertising.com /><link rel=dns-prefetch href=//search.spotxchange.com /><link rel=dns-prefetch href=//static.adsafeprotected.com /><link rel=dns-prefetch href=//imasdk.googleapis.com /><link rel=dns-prefetch href=//geolocation.onetrust.com /><link rel=preconnect href=https://geolocation.onetrust.com /><link rel=dns-prefetch href=//cdn.taboola.com /><link rel=preconnect href=https://cdn.taboola.com /><link rel=dns-prefetch href=//trc.taboola.com /><link rel=preconnect href=https://trc.taboola.com /><link rel=dns-prefetch href=//www.usatodaynetworkservice.com /><link rel=preload as=fetch type=application/json href=https://user.apalachtimes.com/NATN-GUP/user/ crossorigin=use-credentials /><link rel=preload as=script href=/tangstatic/js/pbjsandwich-q1a2z3dc41a7be.min.js /><link rel=preload as=script href=https://c.amazon-adsystem.com/aax2/apstag.js /><link rel=preload as=script href=https://js-sec.indexww.com/ht/p/184808-89514051626416.js /><link rel=preload as=script href=https://static.adsafeprotected.com/iasPET.1.js /><link rel=preload as=script href=https://static.criteo.net/js/ld/publishertag.prebid.js crossorigin/><link rel=preload as=script href=https://securepubads.g.doubleclick.net/tag/js/gpt.js /><link rel=preload as=script href=https://confiant-integrations.global.ssl.fastly.net/r5TdgVvkbv-PeaJCKaQfCh5Xsto/gpt_and_prebid_v3l/config.js /><link rel=preload as=script href=/tangstatic/js/main-q1a2z3eea2a9c8.min.js /><link rel=preload as=script href=https://geolocation.onetrust.com/cookieconsentpub/v1/geo/location/gnt.otgc /><link rel=preload as=script href=https://cdn.taboola.com/libtrc/gannett-network/loader.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/controls-a72d7ef9.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/share-454f9438.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/tealplayer-5aa8c51e.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-comscore-f1701de9.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-gcianalytics-4c420e9b.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-hls-ec6a0617.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/encore-c29e248c.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-ima-a1174258.min.js /><link rel=preload as=fetch href="https://hlsmedia.gannett-cdn.com/authoring/video-renditions/617542ed-1660-4ec6-9be6-d3ba79185dc6/2c4b98a2-97eb-4c2b-bb67-7ec16f6509ef/1080p_30fps,720p_30fps,480p_30fps,master.m3u8?subtitles=3663781001" crossorigin/><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/hls/hls.0.14.9.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/comscore/streamsense-5.1.1.160316.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/ias/ias-3.5.1.min.js /><link rel=preload as=script href=https://s0.2mdn.net/instream/video/client.js /><link rel=preload as=script href=https://imasdk.googleapis.com/js/sdkloader/ima3.js /><meta name=description content="Arrest report for Franklin County, ending Oct. 11"/><meta property=og:description content="Arrest report for Franklin County, ending Oct. 11"/><meta property=fb:pages content=171166446235676 /><meta property=fb:app_id content=2714999428729310 /><link rel=canonical href=https://www.apalachtimes.com/story/news/2020/10/14/arrest-report/3651742001/ /><meta property=og:url content=https://www.apalachtimes.com/story/news/2020/10/14/arrest-report/3651742001/ /><meta property=og:site_name content="Apalachicola Times"/><meta property=og:image content=https://www.apalachtimes.com/tangstatic/sites/natn/og-image-q1a2z37df1164e.png /><meta name=ROBOTS content="NOODP, NOYDIR"/><meta name=google content=notranslate /><meta property=og:type content=article /><script>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</script><style>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</style><meta name=twitter:card content=summary_large_image /><meta name=twitter:site content=@ApalachTimes /><meta name=twitter:creator content=@ApalachTimes /><meta name=twitter:title content="Arrest report"/><meta name=twitter:description content="Arrest report for Franklin County, ending Oct. 11"/></head><body><svg style=display:none><symbol id=gnt_svg_external viewBox="0 0 18 18"><path d="M12.43 5.5H10.5V4H15v4.5h-1.5V6.55l-4.56 4.56-1.06-1.06 4.55-4.55zm1.07 9v-3.75H15V16H3V4h5.25v1.5H4.5v9h9z"/></symbol><svg id=gnt_svg_share_facebook viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#4460a0)><path d="M10.5932 20.9998C6.291 20.3204 3 16.5743 3 12.055 3 7.054 7.0294 3 12 3s9 4.054 9 9.0549c0 4.5198-3.2914 8.266-7.5943 8.9451v-6.3188h2.097l.3991-2.6175h-2.496v-1.6985c0-.716.3486-1.414 1.4666-1.414h1.1349V6.7227s-1.03-.1769-2.0146-.1769c-2.0558 0-3.3995 1.2536-3.3995 3.523v1.9948H8.3081v2.6175h2.2851v6.3186z"/></svg><symbol id=gnt_svg_share_twitter viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#00aaec)><path d="M21 6.776a7.213 7.213 0 0 1-2.12.596 3.778 3.778 0 0 0 1.623-2.095 7.273 7.273 0 0 1-2.346.918A3.642 3.642 0 0 0 15.462 5c-2.038 0-3.692 1.696-3.692 3.787 0 .296.032.585.095.862-3.069-.158-5.79-1.664-7.612-3.958a3.856 3.856 0 0 0-.5 1.906c0 1.313.652 2.472 1.643 3.152a3.626 3.626 0 0 1-1.673-.473v.047c0 1.835 1.273 3.366 2.963 3.713-.31.089-.636.133-.973.133-.238 0-.47-.023-.695-.067.47 1.504 1.833 2.599 3.45 2.628A7.292 7.292 0 0 1 3 18.3 10.282 10.282 0 0 0 8.66 20c6.794 0 10.508-5.77 10.508-10.774 0-.164-.003-.329-.01-.49A7.58 7.58 0 0 0 21 6.776"/></symbol><symbol id=gnt_svg_share_email viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#626262)><path d="M3 5.88c0-.49.4-.88.9-.88h16.2c.5 0 .9.4.9.88v12.24c0 .49-.4.88-.9.88H3.9a.9.9 0 0 1-.9-.88V5.88zm9 5.21L3 6.74v1.74l9 4.35 9-4.35V6.74l-9 4.35z"/></symbol><symbol id=gnt_svg_shareapi viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#000)><path d="M14 5l6 7-6 7V5zm0 4v6c-1.937-.271-3.937.062-6 1s-3.73 2.271-5 4c.909-3.576 2.242-6.242 4-8s4.091-2.758 7-3z"/></symbol></svg><header class=gnt_n onmousedown=event.stopPropagation() onmouseup=event.stopPropagation()><div class=gnt_n_lg_w><button class=gnt_n_sb data-g-r=base_sb data-t-l=${tc}|H1Nav|skipToMainContent aria-label="Skip to main content"></button><a class=gnt_n_lg href=/ aria-label="Apalachicola Times" data-t-l=|H1Nav|logo><svg class=gnt_n_lg_svg id=gnt_svg_lg fill=#303030 preserveAspectRatio="xMinYMid meet" viewBox="0 0 285.6 57.91"><path d="M31.11 20.76h-2.43c-1.72-10.58-4.62-16.53-8.23-17.55v46c0 3.68.63 5.01 3.92 5.25v2.51H6.74v-2.51c3.29-.24 3.92-1.57 3.92-5.25v-46c-3.6 1.02-6.5 6.97-8.23 17.55H0L.39.7h30.32l.4 20.06zM56.42 7.29c0-2.59-.78-3.68-3.29-4V.7h16.3v2.59c-2.51.31-3.21 1.41-3.21 4v43.17c0 2.59.71 3.61 3.21 3.92v2.59h-16.3v-2.59c2.51-.31 3.29-1.33 3.29-3.92V29.7h-9.48v20.76c0 2.59.7 3.61 3.21 3.92v2.59h-16.3v-2.59c2.51-.31 3.29-1.33 3.29-3.92V7.29c0-2.59-.78-3.68-3.29-4V.7h16.3v2.59c-2.51.31-3.21 1.41-3.21 4v19.12h9.48V7.29zm16.76 47.09c2.51-.31 3.29-1.33 3.29-3.92V7.29c0-1.41-.16-2.35-1.02-3.13a3.57 3.57 0 00-2.27-.86V.7h30.01l.23 16.3h-2.51C98.89 7.6 95.44 3.29 89.4 3.29c-2.82 0-3.13.94-3.13 4v19.04c4-.39 6.5-3.68 7.44-10.11h2.59v24.21h-2.59c-.63-6.9-3.45-10.81-7.44-11.36v21.78c0 2.43.63 3.37 2.98 3.37 5.64 0 9.56-5.09 12.22-15.44h2.43l-.31 18.18h-30.4v-2.58zm80.55-33.62h-2.43c-1.72-10.58-4.62-16.53-8.23-17.55v46c0 3.68.63 5.01 3.92 5.25v2.51h-17.63v-2.51c3.29-.24 3.92-1.57 3.92-5.25v-46c-3.6 1.02-6.5 6.97-8.23 17.55h-2.43L123.01.7h30.32l.4 20.06zm19.2 33.62v2.59h-16.3v-2.59c2.51-.31 3.29-1.33 3.29-3.92V7.29c0-2.59-.78-3.68-3.29-4V.7h16.3v2.59c-2.51.31-3.21 1.41-3.21 4v43.17c0 2.59.7 3.61 3.21 3.92m3.6.08c3.06-.47 3.6-2.51 3.6-6.82V6.82c0-2.43-.47-3.06-3.6-3.53V.7h15.91l5.8 32.21L204.35.7h15.44v2.59c-2.82.24-3.45 1.33-3.45 4.47v42c0 3.06.7 4.39 3.45 4.7v2.51h-17.47v-2.51c3.68-.47 4.55-1.88 4.55-5.72V3.68L196.6 56.96h-3.53L183.51 2.9v44.74c0 4.23.63 6.27 4.39 6.82v2.51h-11.36v-2.51zm46.94-.08c2.51-.31 3.29-1.33 3.29-3.92V7.29c0-1.41-.16-2.35-1.02-3.13a3.57 3.57 0 00-2.27-.86V.7h30.01l.23 16.3h-2.51c-2.04-9.4-5.48-13.71-11.52-13.71-2.82 0-3.13.94-3.13 4v19.04c4-.39 6.5-3.68 7.44-10.11h2.59v24.21H244c-.63-6.9-3.45-10.81-7.44-11.36v21.78c0 2.43.63 3.37 2.98 3.37 5.64 0 9.56-5.09 12.22-15.44h2.43l-.31 18.18h-30.4v-2.58zm34.24-15.75H261c2.66 10.81 7.29 16.3 12.54 16.3 3.53 0 6.03-2.51 6.03-6.35 0-4.94-3.84-8.85-9.48-14.57-3.92-3.92-7.29-6.9-9.25-9.87a18.78 18.78 0 01-3.29-10.34c0-7.92 5.33-13.8 11.75-13.8 3.6 0 6.11 2.35 7.91 2.35 1.17 0 2.19-.7 2.98-2.12h2.59v18.34h-3.13c-2.35-10.5-5.95-15.75-10.66-15.75a5.26 5.26 0 00-5.48 5.49c0 4.54 4 8.23 9.95 14.03 1.72 1.65 4.7 4.15 7.99 8.54a21 21 0 014.15 12.62c0 8.46-5.25 14.34-12.07 14.34-4.62 0-7.52-2.66-9.48-2.66-1.41 0-2.27.94-3.68 2.74h-2.66V38.63z"/></svg></a></div><div class="gnt_n_sm gnt_n_sm__ne gnt_n_nc__hbn"><a class=gnt_n_sm_a data-u-sr="anon reg" href="https://subscribe.apalachtimes.com/specialoffer?gps-source=CPNBAR&itm_campaign=2020SLJ&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.apalachtimes.com%2Fstory%2Fnews%2F2020%2F10%2F14%2Farrest-report%2F3651742001%2F" target=_blank rel=noopener data-t-l=|H1Nav|nanobar elementtiming=nav-submsg><div class=gnt_n_sm_a_pt>SUBSCRIBE NOW</div>99¢ for the first month</a></div><div class="gnt_n_sm gnt_n_nc__hbn"><a class=gnt_n_sm_a data-u-sr="anon reg" href="https://subscribe.apalachtimes.com/specialoffer?gps-source=CPMASTHEAD&itm_campaign=2020SLJ&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.apalachtimes.com%2Fstory%2Fnews%2F2020%2F10%2F14%2Farrest-report%2F3651742001%2F" target=_blank rel=noopener data-t-l=|H1Nav|headersubscribecallout elementtiming=nav-submsg><div class=gnt_n_sm_a_pt>SUBSCRIBE NOW</div>99¢ for the first month</a></div><nav class=gnt_n_mn aria-label="Global navigation"><a class="gnt_n_mn_l gnt_n_mn_l__fi gnt_n_mn_ce gnt_n_mn_l__se" href=/news/ data-t-l=|H1Nav|news elementtiming=nav-item>News</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/sports/ data-t-l=|H1Nav|sports>Sports</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/entertainment/ data-t-l=|H1Nav|entertainment>Entertainment</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/lifestyle/ data-t-l=|H1Nav|lifestyle>Lifestyle</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/opinion/ data-t-l=|H1Nav|opinion>Opinion</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=https://www.usatoday.com/ data-t-l=|H1Nav|nation-world>Nation / World</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=https://www.legacy.com/obituaries/starfl/ data-t-l=|H1Nav|obituaries>Obituaries</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=https://floridapublicnotices.com/ data-t-l=|H1Nav|legals>Legals</a><div class=gnt_n_dd_w data-g-r="nav_ce nav_sh"><button class="gnt_n_dd_bt gnt_n_mn_ce" data-g-r=nav_ab data-g-tn=navgdp data-g-ltn=navgd data-t-l=${tc}|H1Nav|caret aria-label="Global Navigation" aria-haspopup=true aria-expanded=false><svg class=gnt_n_dd_bt_svg viewBox="0 0 10 6"><path d="M5 3.35L8.64 0 10 1.4 5 6 0 1.4 1.36 0z"/></svg></button></div><div class=gnt_n_us><div class=gnt_n_se data-g-r=nav_ce><a class="gnt_n_se_a gnt_n_mn_ce" data-g-r=nav_ab data-g-tn=navse href=/search/ data-t-l=${tc}|H1Nav|search title=Search aria-label=Search aria-haspopup=true aria-expanded=false><svg class=gnt_n_se_a_svg viewBox="0 0 24 24"><path d="M15.75 14.33l4.96 4.96-1.42 1.42-4.96-4.96a6.5 6.5 0 1 1 1.41-1.41zM10.5 15a4.5 4.5 0 1 0 0-9 4.5 4.5 0 0 0 0 9z"/></svg></a></div><a class=gnt_n_us_sb data-u-sr="anon reg" href="https://subscribe.apalachtimes.com/specialoffer?gps-source=CPTOPNAVBAR&itm_campaign=2020SLJ&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.apalachtimes.com%2Fstory%2Fnews%2F2020%2F10%2F14%2Farrest-report%2F3651742001%2F" target=_blank rel=noopener data-t-l=|H1Nav|subscribe elementtiming=nav-subbt>Subscribe</a></div></nav></header><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__hi"><div id=ad-slot-7103-fl-apalachicola-C6734-high_impact-news-1 class="gnt_x_sl gnt_x_hi"></div></aside><div class=gnt_bc></div><div class=gnt_cw_w><a class=gnt_cw_sl data-g-r=base_xbutton href=/news/ data-t-l=|modalclose|overlay aria-label=Close aria-hidden=true tabindex=-1></a> <a class="gnt_cw_sl gnt_cw_sl__ed" data-g-r=base_xbutton href=/news/ data-t-l=|modalclose|overlay aria-label=Close aria-hidden=true tabindex=-1></a><main class=gnt_cw><div class=gnt_ar_lbl aria-label=News data-c-ssts=NEWS></div><article class=gnt_pr><h1 class=gnt_ar_hl elementtiming=ar-headline>Arrest report</h1><div class=gnt_ar_pb>The Apalachicola Times</div><div class=gnt_ar_dt aria-label="Published 11:21 a.m. ET Oct. 14, 2020"></div><div class=gnt_ss data-g-r=base_sc data-ss-u=https://www.apalachtimes.com/story/news/2020/10/14/arrest-report/3651742001/ data-ss-t="Arrest report" data-ss-d="Arrest report for Franklin County, ending Oct. 11"><a class=gnt_ss_a href="https://www.facebook.com/dialog/share?display=popup&app_id=2714999428729310&href=https%3A%2F%2Fwww.apalachtimes.com%2Fstory%2Fnews%2F2020%2F10%2F14%2Farrest-report%2F3651742001%2F" data-g-r=base_si data-ss-a=f data-t-l=${tc}|navbar-share-top|facebook aria-label="Share to Facebook" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_facebook /></svg></a><a class=gnt_ss_a href="http://twitter.com/share?url=https%3A%2F%2Fwww.apalachtimes.com%2Fstory%2Fnews%2F2020%2F10%2F14%2Farrest-report%2F3651742001%2F&text=Arrest%20report&via=ApalachTimes" data-g-r=base_si data-ss-a=t data-t-l=${tc}|navbar-share-top|twitter aria-label="Share to Twitter" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_twitter /></svg></a><a class=gnt_ss_a href="mailto:?subject=Arrest%20report%20-%20from%20Apalachicola%20Times&body=Arrest%20report%0A%0AArrest%20report%20for%20Franklin%20County%2C%20ending%20Oct.%2011%0A%0ACheck%20out%20this%20story%20on%20apalachtimes.com%3A%20https%3A%2F%2Fwww.apalachtimes.com%2Fstory%2Fnews%2F2020%2F10%2F14%2Farrest-report%2F3651742001%2F" data-t-l=${tc}|navbar-share-top|email aria-label="Share by email"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_email /></svg></a><button class="gnt_ss_a gnt_ss_a__sa" data-g-r=base_si data-ss-a=s data-t-l=${tc}|navbar-share-top|shareapi aria-label="Share natively"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_shareapi /></svg></button></div><aside class="gnt_em gnt_em_vp__tavp gnt_em__el" aria-label="Video - Surprised parents scream and dance when son walks in"><div class="" data-g-r=vp_tp data-c-vt=teal data-t-pl=teal-automatedvideoplayer aria-live=polite><div class="gnt_em_vp_a gnt_em_vp__tavp_a" data-g-r="vp_ap vp_tg" data-c-vpattrs="{&#34;muted&#34;:true,&#34;bContent&#34;:false,&#34;an&#34;:&#34;fl-apalachicola-C6734&#34;,&#34;pn&#34;:&#34;Apalachicola Times&#34;,&#34;vidNum&#34;:1,&#34;avp&#34;:true}" data-c-vpdata="{&#34;adsEnabled&#34;:true,&#34;awsPath&#34;:&#34;lifestyle/humankind&#34;,&#34;byline&#34;:&#34;Humankind&#34;,&#34;canonicalURL&#34;:&#34;&#34;,&#34;contentSourceCode&#34;:&#34;USAT&#34;,&#34;createDate&#34;:&#34;2020-10-15T15:05:40Z&#34;,&#34;credit&#34;:&#34;Humankind, USA TODAY&#34;,&#34;duration&#34;:56000,&#34;headline&#34;:&#34;Surprised parents scream and dance when son walks in&#34;,&#34;hlsURL&#34;:&#34;https://hlsmedia.gannett-cdn.com/authoring/video-renditions/617542ed-1660-4ec6-9be6-d3ba79185dc6/2c4b98a2-97eb-4c2b-bb67-7ec16f6509ef/1080p_30fps,720p_30fps,480p_30fps,master.m3u8?subtitles=3663781001&#34;,&#34;id&#34;:&#34;3663781001&#34;,&#34;image&#34;:{&#34;url&#34;:&#34;https://www.gannett-cdn.com/presto/2020/10/15/USAT/d7611318-f343-4ed6-a26c-ac3d0cfb00f9-Courtesy_the_Harvey_family_16x9_THUMB.png&#34;,&#34;opto&#34;:true},&#34;initialPublishDate&#34;:&#34;2020-10-15T15:05:40Z&#34;,&#34;keywords&#34;:&#34;Family Gatherings and Reunions,Sports,Atlanta,Parents,Video Syndication - USAT,Video Syndication – International&#34;,&#34;mp4URL&#34;:&#34;https://downloadmedia.gannett-cdn.com/authoring/video-renditions/617542ed-1660-4ec6-9be6-d3ba79185dc6/2c4b98a2-97eb-4c2b-bb67-7ec16f6509ef/1080p_30fps.mp4&#34;,&#34;origin&#34;:&#34;USA TODAY&#34;,&#34;pageURL&#34;:{&#34;long&#34;:&#34;https://www.usatoday.com/videos/life/humankind/2020/10/15/surprised-parents-scream-and-dance-when-son-walks/3663781001/&#34;},&#34;promoBrief&#34;:&#34;After Coley Harvey's COVID-19 test came back negative, he drove from Chicago to Atlanta to finally see his parents after months of missing them.&#34;,&#34;propertyName&#34;:&#34;USATODAY&#34;,&#34;publishDate&#34;:&#34;2020-10-15T15:05:40Z&#34;,&#34;series&#34;:&#34;&#34;,&#34;ssts&#34;:{&#34;section&#34;:&#34;life&#34;,&#34;subsection&#34;:&#34;humankind&#34;,&#34;topic&#34;:&#34;&#34;,&#34;subtopic&#34;:&#34;&#34;},&#34;tags&#34;:[{&#34;id&#34;:&#34;c644cb27-cc8b-43c0-b8aa-b7b263830217&#34;,&#34;name&#34;:&#34;Family Gatherings and Reunions&#34;},{&#34;id&#34;:&#34;5db560e4-56d0-49e5-a654-1dbd85f01c90&#34;,&#34;name&#34;:&#34;Sports&#34;},{&#34;id&#34;:&#34;46517675-2c4f-4e0c-83fa-31e58686ff21&#34;,&#34;name&#34;:&#34;Atlanta&#34;},{&#34;id&#34;:&#34;62986823-b2a5-4184-adc2-3a95bae7d854&#34;,&#34;name&#34;:&#34;Parents&#34;},{&#34;id&#34;:&#34;6f55135f-3b5e-490d-8a52-a3b8e1f11ee7&#34;,&#34;name&#34;:&#34;Video Syndication - USAT&#34;},{&#34;id&#34;:&#34;abb1b69c-143a-47e0-9004-50120aa6b80d&#34;,&#34;name&#34;:&#34;Video Syndication – International&#34;}],&#34;title&#34;:&#34;Surprised parents scream and dance when son walks in&#34;,&#34;url&#34;:&#34;/videos/life/humankind/2020/10/15/surprised-parents-scream-and-dance-when-son-walks/3663781001/&#34;}"></div><button class=gnt_em_vp_db aria-label="Close autoplay video player" data-t-l=${tc}|tealplayer|automated-playerClose><svg viewBox="0 0 16 16"><path d="M9 7.625L13.125 3.5 14.5 4.875 10.375 9l4.125 4.125-1.375 1.375L9 10.375 4.875 14.5 3.5 13.125 7.625 9 3.5 4.875 4.875 3.5 9 7.625z"/></svg></button><div class=teal-video-wrap><video poster="https://www.gannett-cdn.com/presto/2020/10/15/USAT/d7611318-f343-4ed6-a26c-ac3d0cfb00f9-Courtesy_the_Harvey_family_16x9_THUMB.png?width=660&height=371&fit=crop&format=pjpg&auto=webp" title="Surprised parents scream and dance when son walks in" muted playsinline elementtiming=avp-video></video></div></div></aside><div class=gnt_ar_b><p class=gnt_ar_b_p><em>The following report is provided by the Franklin County Sheriff’s Office. Arrests listed this week were made by officers from the Franklin County Sheriff’s Office. All defendants are to be considered innocent until proven guilty in a court of law.</em></p><p class=gnt_ar_b_p><u><strong>Sept. 28</strong></u></p><p class=gnt_ar_b_p><strong>Shara Mitchell,</strong> 36, Eastpoint, possession of methamphetamine, possession or use of narcotic equipment; (FCSO)</p><p class=gnt_ar_b_p><u><strong>Oct. 5</strong></u></p><p class=gnt_ar_b_p><strong>David L. Geter,</strong> 33, Crawfordville, violation of felony probation; (FCSO)</p><p class=gnt_ar_b_p><u><strong>Oct. 8</strong></u></p><p class=gnt_ar_b_p><strong>Joshua Waring Cooper</strong>, 30, Apalachicola, driving on a permanently revoked drivers license; released on own recognizance (FCSO)</p><p class=gnt_ar_b_p><u><strong>Oct. 9</strong></u></p><p class=gnt_ar_b_p><strong>Thornton Lee Moses</strong>, 20, Eastpoint, possession of methamphetamine; $2,500 bond (FCSO)</p><p class=gnt_ar_b_p><u><strong>Oct. 10</strong></u></p><p class=gnt_ar_b_p><strong>Allen Shakeem Blanchard</strong>, 27, Tallahassee, lewd and lascivious behavior conducted by person age 18 or older; $2,500 bond (FCSO)</p><p class=gnt_ar_b_p><u><strong>Oct. 11</strong></u></p><p class=gnt_ar_b_p><strong>Kalie Nicole Galassow</strong>, 27, Crawfordville, DUI – first offense, refusal to submit to a DUI test; $750 bond (FCSO)</p></div><div class=gnt_ss data-g-r=base_sc data-ss-u=https://www.apalachtimes.com/story/news/2020/10/14/arrest-report/3651742001/ data-ss-t="Arrest report" data-ss-d="Arrest report for Franklin County, ending Oct. 11"><a class=gnt_ss_a href="https://www.facebook.com/dialog/share?display=popup&app_id=2714999428729310&href=https%3A%2F%2Fwww.apalachtimes.com%2Fstory%2Fnews%2F2020%2F10%2F14%2Farrest-report%2F3651742001%2F" data-g-r=base_si data-ss-a=f data-t-l=${tc}|navbar-share-bottom|facebook aria-label="Share to Facebook" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_facebook /></svg></a><a class=gnt_ss_a href="http://twitter.com/share?url=https%3A%2F%2Fwww.apalachtimes.com%2Fstory%2Fnews%2F2020%2F10%2F14%2Farrest-report%2F3651742001%2F&text=Arrest%20report&via=ApalachTimes" data-g-r=base_si data-ss-a=t data-t-l=${tc}|navbar-share-bottom|twitter aria-label="Share to Twitter" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_twitter /></svg></a><a class=gnt_ss_a href="mailto:?subject=Arrest%20report%20-%20from%20Apalachicola%20Times&body=Arrest%20report%0A%0AArrest%20report%20for%20Franklin%20County%2C%20ending%20Oct.%2011%0A%0ACheck%20out%20this%20story%20on%20apalachtimes.com%3A%20https%3A%2F%2Fwww.apalachtimes.com%2Fstory%2Fnews%2F2020%2F10%2F14%2Farrest-report%2F3651742001%2F" data-t-l=${tc}|navbar-share-bottom|email aria-label="Share by email"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_email /></svg></a><button class="gnt_ss_a gnt_ss_a__sa" data-g-r=base_si data-ss-a=s data-t-l=${tc}|navbar-share-bottom|shareapi aria-label="Share natively"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_shareapi /></svg></button></div><div class="gnt_tb gnt_tbb"><div id=gnt_tbw_1></div></div></article><div class=gnt_rr><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__pf"><div id=ad-slot-7103-fl-apalachicola-C6734-poster-news-2 class="gnt_x_sl gnt_x_p"></div></aside><div class="gnt_tb gnt_tbr" data-t-l=${tc}|rightRailTaboolaRecirc|click><div id=gnt_tbw_2></div></div><div class="gnt_m gnt_m_fs"><a href="https://cm.apalachtimes.com/site-feedback/?platform=Tangent-Desktop&url=https%3A%2F%2Fwww.apalachtimes.com%2Fstory%2Fnews%2F2020%2F10%2F14%2Farrest-report%2F3651742001%2F&marketName=apalachtimes&cta=Right-Rail" class=gnt_m_fs_a data-t-l=${tc}survey_click_story aria-label="Notice our new look? As you get used to things, please let us know what you think!"></a></div><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__st"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-fl-apalachicola-C6734-poster_scroll-news-3 class="gnt_x_sl gnt_x_sl__st gnt_x_p"></div></aside></div><div class=gnt_xbr><a class=gnt_ar_xb data-g-r=base_xbutton href=/news/ data-t-l=|modalclose|x aria-label=Close></a></div></main></div><footer class=gnt_ft data-g-r="lazy lazy_p" data-gl-type=method data-gl-method=shbd><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__lb"><div id=ad-slot-7103-fl-apalachicola-C6734-leaderboard_btf-news-4 class=gnt_x_lb></div></aside><svg class="gnt_ft_lg gnt__hbd" data-g-r=lazy_c alt="Apalachicola Times - Part of the USA Today Network"><use xlink:href=#gnt_svg_lg alt/></svg><div class="gnt_ft_lw gnt__hbd" data-g-r=lazy_c><div class=gnt_ft_ls aria-label=About><a href=http://www.gannett.com/careers/ class=gnt_ft_a data-t-l=|footer|about|careers>Careers</a> <a href=https://cm.apalachtimes.com/accessibility/ class=gnt_ft_a data-t-l=|footer|about|accessibility>Accessibility</a> <a href=https://www.apalachtimes.com/sitemap/ class=gnt_ft_a data-t-l=|footer|about|site-map>Site Map</a> <a href=https://floridapublicnotices.com/ class=gnt_ft_a data-t-l=|footer|about|legals>Legals</a> <a href=https://cm.apalachtimes.com/ethical-conduct/ class=gnt_ft_a data-t-l=|footer|about|our-ethical-principles>Our Ethical Principles</a> <a href=https://cm.apalachtimes.com/terms/ class=gnt_ft_a data-t-l=|footer|about|terms-of-service>Terms of Service</a> <a href=https://cm.apalachtimes.com/privacy/ class=gnt_ft_a data-t-l=|footer|about|privacy-policy>Privacy Policy</a> <a href=https://cm.apalachtimes.com/privacy-policy/ class=gnt_ft_a data-t-l=|footer|about|california-privacy-right>Your California Privacy Rights / Privacy Policy</a> <a href=https://cm.apalachtimes.com/cookie-policy# class="gnt_ft_a gnt_ft_a__b" data-t-l=|footer|about|cookie-policy>Do Not Sell My Info / Cookie Policy</a></div><div class=gnt_ft_ls aria-label=Support><a href=https://help.apalachtimes.com/contact-us class=gnt_ft_a data-t-l=|footer|support|contact-us>Contact Us</a> <a href=https://supportlocal.usatoday.com/ class=gnt_ft_a data-t-l=|footer|support|support-local-businesses>Support Local Business</a> <a href=https://localiq.com/markets/florida/ class=gnt_ft_a data-t-l=|footer|support|advertise-your-business>Advertise Your Business</a> <a href=https://cm.apalachtimes.com/advertising-terms-conditions class=gnt_ft_a data-t-l=|footer|support|advertising-terms-and-conditions>Advertising Terms and Conditions</a> <a href="http://www.verican.us/cod6/saleitem.do?catalog=newsherald" class=gnt_ft_a data-t-l=|footer|support|buy-and-sell>Buy and Sell</a> <a href=https://help.apalachtimes.com/ class=gnt_ft_a data-t-l=|footer|support|help-center>Help Center</a> <a href=https://account.apalachtimes.com/ class=gnt_ft_a data-t-l=|footer|support|my-account>My Account</a> <a href="https://gmiiservices.newscyclecloud.com/cgi-bin/cmo_gmi-c-cmdb-fla-01.sh/custservice/web/login.html?siteid=APT" class=gnt_ft_a data-t-l=|footer|support|my-print-account>My Print Account</a> <a href=https://cm.apalachtimes.com/site-feedback/ class=gnt_ft_a data-t-l=|footer|support|feedback>Give Feedback</a></div><div class=gnt_ft_ls aria-label="Stay Connected"><a href=https://subscribe.apalachtimes.com/ class=gnt_ft_a data-t-l=|footer|stay-connected|subscribe-today>Subscribe Today</a> <a href=https://profile.apalachtimes.com/newsletters/manage class=gnt_ft_a data-t-l=|footer|stay-connected|newsletters>Newsletters</a> <a href=https://www.facebook.com/Apalachtimes/ class=gnt_ft_a data-t-l=|footer|stay-connected|facebook>Facebook</a> <a href=http://www.twitter.com/ApalachTimes class=gnt_ft_a data-t-l=|footer|stay-connected|twitter>Twitter</a></div><div class=gnt_ft_ls aria-label="Our Partners"><a href=/jobs class=gnt_ft_a data-t-l=|footer|our-partners|jobs>Jobs</a> <a href=/section/cars class=gnt_ft_a data-t-l=|footer|our-partners|cars>Cars</a> <a href=/homes class=gnt_ft_a data-t-l=|footer|our-partners|homes>Homes</a> <a href=http://marketplace.apalachtimes.com/classifieds class=gnt_ft_a data-t-l=|footer|our-partners|classifieds>Classifieds</a> <a href=https://www.reviewed.com/ class=gnt_ft_a data-t-l=|footer|our-partners|reviewed>Reviewed.com</a> <a href=https://www.10best.com/ class=gnt_ft_a data-t-l=|footer|our-partners|10best>10Best</a> <a href=http://www.reachlocal.com/us/en class=gnt_ft_a data-t-l=|footer|our-partners|reach-local>Reach Local</a></div></div><div class=gnt_ft_cr elementtiming=footer-cr>© 2020 www.apalachtimes.com. All rights reserved.</div></footer><script>if(gnt.luxEnabled&&(LUX={ae:[],al:[]},setTimeout(function(){gnt.addScript('/tangstatic/js/perf-q1a2z3ad2de3ef.min.js',!0)},3E3),addEventListener("error",a=>{LUX.ae.push(a)}),"function"===typeof PerformanceObserver))try{LUX.al.po=new PerformanceObserver(a=>{LUX.al.push(...a.getEntries())}),LUX.al.po.observe({type:"longtask",buffered:!0})}catch(a){};</script><script>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</script><script async src=/tangstatic/js/main-q1a2z3eea2a9c8.min.js onerror="document.querySelectorAll('.gnt__hbd').forEach(e=>e.classList.remove('gnt__hbd'))"></script><script type="gnt/tmpl" data-tmpl-key=navgdp><div class="gnt_n_dd_oy gnt_n_dd__sz" data-g-r=nav_oy></div><div class="gnt_n_dd gnt_n_dd__sz" data-g-r="nav_dd nav_te nav_ff" tabindex=0></div>|styles|[data-g-s=nav_ao] .gnt_n_dd_bt_svg{transform:rotate(180deg);background:currentColor;fill:#303030}.gnt_n_dd_oy{display:none;left:0;right:0;height:calc(var(--gnt-vh,100vh) - 100px - var(--gnt-sh,0px))}.gnt_n_dd{overscroll-behavior-y:contain;overflow:auto;overflow-x:hidden;box-sizing:border-box;display:none;width:385px;height:calc(var(--gnt-vh,100vh) - 100px - var(--gnt-sh,0px));margin:0 0 0 -20px;padding:7px 20px 0 32px;border-top:5px solid #0098fe;background:#303030;color:#fff}[data-g-s=nav_ao] .gnt_n_dd__sz{display:block;position:absolute}</script><script type="gnt/tmpl" data-tmpl-key=navse><form class=gnt_n_se_fm data-g-r=nav_dd action=/search/ role=search><input class=gnt_n_se_fm_qr data-g-r=nav_pf name=q placeholder="What can we help you find?" mozactionhint=search enterkeyhint=search aria-label="Search query"/><button class=gnt_n_se_fm_sm data-t-l=${se}|H1Nav|search| aria-label=Submit><svg class=gnt_n_se_fm_sm_svg viewBox="0 0 18 18"><path d="M12.28 9.76H2V7.74h10.28l-2.23-2.31L11.43 4 16 8.75l-4.57 4.75-1.38-1.43 2.23-2.31z"/></svg></button></form>|styles|.gnt_n_se_fm{display:none;align-items:center;justify-content:center;position:absolute;left:0;right:0;height:180px;padding:0 0 15px;border-top:5px solid #0098fe;background:#303030}[data-g-s~=nav_ao] .gnt_n_se_fm{display:flex}.gnt_n_se_fm_qr{width:492px;height:46px;padding:0 50px 0 0;border-style:solid;border-width:0 0 2px;border-color:#fff;border-radius:0;outline:0;background:0 0;color:#fff;font:700 28px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif}.gnt_n_se_fm_qr::placeholder{opacity:1;color:#fff}.gnt_n_se_fm_qr:-webkit-autofill{box-shadow:inset 0 46px #303030;-webkit-text-fill-color:#fff}.gnt_n_se_fm_sm{width:60px;height:50px;border:0;margin:0 -15px 0 -45px;padding:0;outline-offset:-8px;fill:#fff;background:0 0;cursor:pointer}.gnt_n_se_fm_sm:hover{fill:#e0e0e0}.gnt_n_se_fm_sm_svg{width:42px;height:42px;margin-top:3px;stroke:#303030;stroke-width:.5px}</script><link rel=preload as=fetch type=application/json crossorigin=use-credentials href=/global-q1a2z3MCDN+h0YPXCzTFjLTgWU5NEpAI.min.json /><link rel=dns-prefetch href=//images.taboola.com /><link rel=preconnect href=https://images.taboola.com /><script type=application/ld+json>{"@context":"http://schema.org","@type":"NewsArticle","headline":"Arrest report","description":"Arrest report for Franklin County, ending Oct. 11","url":"https://www.apalachtimes.com/story/news/2020/10/14/arrest-report/3651742001/","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.apalachtimes.com/story/news/2020/10/14/arrest-report/3651742001/"},"datePublished":"2020-10-14T15:21:06Z","dateCreated":"2020-10-14T15:21:06Z","dateModified":"2020-10-14T15:21:06Z","articleSection":"news","publisher":{"@type":"Organization","name":"The Apalachicola Times","logo":{"@type":"ImageObject","url":"https://www.gannett-cdn.com/sites/apalachtimes/images/site-nav-logo@2x.png","height":80,"width":297}},"author":"The Apalachicola Times","keywords":["ssts:news","type:story","tag:Arrests","tag:Franklin County, FL"],"metadata":"{\"id\":\"3651742001\",\"siteCode\":\"NATN\",\"contentSourceCode\":\"NATN\",\"ssts\":\"news\",\"type\":\"story\"}"}</script></body></html>